Vue.jsエラー。gyp: No Xcode or CLT version detected!

vue create <プロジェクト名>コマンドを入力すると以下のようなエラーがでた。

gyp: No Xcode or CLT version detected!

XcodeあるいはCLTのバージョンがおかしいらしい。

解決方法について

GitHubのnode-gypにあったものを参考にした。

sudo rm -rf $(xcode-select -print-path)
sudo rm -rf /Library/Developer/CommandLineTools
xcode-select --install

これで再度、vue create <プロジェクト名>コマンドを入力するとエラーも出ずにプロジェクトが作成された。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です